Elevated error rates for Postman Mock
Incident Report for Postman
Resolved
We have tested the effectiveness of the patch deployed to the service application and it has been verified to work as expected.
Posted Mar 10, 2020 - 10:34 UTC
Monitoring
We have deployed a fix to production and are actively testing and monitoring the system.
Posted Mar 10, 2020 - 10:09 UTC
Update
We are updating our service application with the patch that would prevent this issue from recurring. Normal usage of the product will not be affected during this.
Posted Mar 10, 2020 - 09:39 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2020 - 09:05 UTC
Identified
We experienced an elevated error rate for Postman mock deletion action at 09:30 UTC. A percentage of users would have experienced failure while trying to delete Postman Mocks.

We’ve identified the issue to have been caused by a code flow that was resulting in data access lock. We have temporarily addressed the issue by unlocking the affected storage system which has resulted in systems to be temporarily restored to normal operations.

We are actively working towards deploying a hotfix that would permanently fix this issue.
Posted Mar 10, 2020 - 09:05 UTC
This incident affected: Postman App, Postman Dashboard, Postman Mocks, and Postman API.